_images/app_workflows.png

20. Workflow Simlytiks Mapper

Workflow => Simlytiks is a new feature that is now available in PPT Reporter worker. It includes the mapping of any workflow input/output to Simlytiks to provide full configuration dynamically.

Different steps involved in PPT reporter mapping.

  1. Basic info and settings.
  2. Pages and Visualization.
  3. KPI
  4. Groups & Filters
  5. Review

20.1. Basic info and settings

In Basic info and settings we provide basic information required to create a visualization, such as Title , Page layout, Default view, Viz preview, Default colcor scheme, Export layout and PPT template.

Basic info and settings


Basic info


20.2. Pages and Visualization

In Pages and Visualizations, We create number of pages and Visualizations required in creating expected Visualization. We can also select the layout for the visualization to be created.

Pages and Visualization


In Workflow Simlytiks Mapper worker, when a new page is added in Pages & Visualizations tab, it is set as active by default.


Simlytiks Reporter now has a way of filtering out invalid visualizations for a particular page that can be accidentally created in Configure Manually. We can change the layout in Simlytiks visualizations to eliminate the Visualizations


PPT Reporter worker now supports Grouping in Colorby tab for the visualizations created using Configure manually.


20.3. KPI

In this step, we select Inputs, Ojectives and Targets for Simlytiks Dataset.

KPI


20.4. Groups & Filters

We can create Groups & Filters for the Visualizations and save them to view in the Review and output of the Reporter.

Groups & Filters


20.5. Word Template

A new tab is added within Configure Manually which allows the Word template to be set up that gets saved to the layout in Workflows Reporter Mapper.



20.6. Review

In Review tab, we see settings and mappings we created from step1 on left handside and Preview of the visualizations created on the right side which can be saved and configured.

Review


20.7. Mapping of Inputs/Outputs

We have inputs/outputs from all the workers available on the right while building a simlytiks reporter. We can search these inputs/outputs and map them to the inputs in the above 5 steps of creating a simlytiks setting visualization. Once mapped we see the same mapped inputs/outputs in the Review and also in the output of the Reporter.


We see the actual names of the input/output instead of Internal Ids when we map inputs in PPT Reporter worker

Input/Output names



20.8. Context menu options

Report Generators have new context menu options to View Report and Download Report. These options will show up ONLY if the worker has a report available


20.9. Save and continue options

In Workflow Simlytiks Mapper, the configurator now has Cancel button and Save & Close button in the footer beside Continue button.

Cancel, Save and Close


20.10. Consolidated outputs

In output, we have new outputs called Consolidated simlytiks report, Consolidated ZIP and Consolidated reports.

Consolidated outputs


20.11. Clone, Copy and Paste

Now we are able to Clone charts, copy visualizations and paste on to the other panel in Workflow Simlytiks Reporter Mapper worker.


20.12. Inputs to Dataset workers

Input for any Dataset worker can now come from the output of the Workflow Reporter worker Dataset in Workflows.


ML worker’s dataset output can be used as input to the PPT Reporter worker and we can view the output dataset in Simlytiks overview table after execution.


20.13. Advanced Configuration

PPT Reporter worker template input now has a new option called Advanced Configuration which opens up the old Configurator that shows Simlytiks on the left and the entire Worker I/O tab on the right. The charts are created by dragging & dropping the inputs on to the viz containers.


PPT Reporter worker’s Advanced Configuration input now has Save & Close button, Cancel button in the footer.

Cancel, Save and Close


Advanced Configuration in PPT reporter worker now shows settings on the right that can be dragged and dropped within Simlytiks. One of the settings that is supported as of now is the schema groups.


Improvement in opening a PPT reporter worker performance when the worker has Newton/Curves in it. Opening a PPT reporter with Curves is easy and takes less time to load the curves.


20.14. Simlytiks ZIP and Consolidated Simlytiks ZIP Output

PPT Reporter worker has two new outputs called Simlytiks ZIP and Collaborated Simlytiks ZIP. These are file outputs containing Simlytiks outputs. We can download the Zip files and upload them in Simlytiks.


Simlytiks ZIP output from PPT Reporter worker can be used as input for the Workers (for example: SIMLYTIKS_CREATE_FROM_FILE) and output is viewed.


If the reporter worker has multiple datasets OR if it has collaborations with other reporters, the View Simlytiks or View Collaborated Simlytiks will show multiple sheets.


Multiple Datasets in PPT Reporter worker are available in Carousel view.


Reporter Blob Download as PPT is now faster in PPT reporter worker.



20.15. External Images

View Simlytiks output in PPT Reporter worker now has a new button in the top right called ‘External Images’ which shows sidebar of the images list including a screenshot of the workflow and all workers. These can be dragged & dropped on an empty viz container or an existing viz container just like any other chart.


Below is the video shows how to create or map the Simlytiks in the Workflow Reporter and view output after executing the Reporter.


20.16. Merge Datasets

In PPT Reporter worker, if the dataset input is dependent on multiple datasets from previous workers, then a new option will show up called ‘Merge dataset’ which will internally merge them into one dataset and use it for Configuration/Simlytiks.


20.17. Enable PPT Mode

PPT Reporter worker has new settings in Options tab called Enable PPT mode, which when enabled will open the Reporter Viewer by default every time this worker is opened.


New Mode options such as Consolidated PPT and Consolidated Simlytiks are available in PPT Reporter Worker Options tab.

Mode options


20.18. Simlytiks View

PPT Reporter worker has a new input called Simlytiks View which will change the Simlytiks outputs default View.


If Reporter worker is used within an iteration and if we observe the Simlytiks dataset ZIP output within the Iteration, this combined dataset can now be used outside the iteration within a reporter to create the collaborated Simlytiks which will show all the combined datamodels.


Added new Input option in Reporter Worker to choose the active sheet in Consolidated Simlytiks Output in Workflows.


20.19. Views

In PPT Reporter worker, a message pops up alerting a reset of previously set configurations when we switch between the views while creating or configuring the visualizations in the worker.


20.20. Empty Dataset

If a dataset is not added in the input of the PPT reporter worker, the first step when we click on Configure Manually will be a drop zone where a dataset can be uploaded which will be used to create the corresponding layout.​


20.21. Mapping of Unit system

Configure Manually in PPT reporter now supports Mapping of Unit system and ANY SCHEMA ATTRIBUTE using the Schema Table tab which will be saved and carried over to View Simlytiks Output.


In configure manually, when the right hand side worker I/O is dragged and dropped onto any setting within the left panel (Basic tab, KPI tab, Pages & visualizations tab), the mapped string will now show the actual Worker name and Input/Output name instead of the internal IDs.


In PPT Reporter/Mapper worker we can click on the name of Steps and switch to that step.