_images/app_workflows.png

7. ViewData Viewing Data

In this section, we’ll go over the ways we can view results and data after execution of our workflow.

7.1. Worker Results

We can view results for individual workers by clicking on them in run mode.

Figure 1: Click on Worker


Here, we are reviewing the Curves Overlay worker inputs and outputs from the execution. Click on any of the View Buttons to see the data results.

Figure 2: Curves Overlay Execution Overview


We’re looking at Curves Overlay output in the Curve Results Viewer.

Figure 3: Curves Overlay Output Results


7.2. Viewer Results

Under the eye icon in the left-side menu, we can view all data inputed and extracted from our execution. For example, we can view all curves which includes all input and output curves.

Figure 4: Viewers: View All Curves


Here, we can use the right side-panel to navigated through all the curves in our workflow.

Figure 5: View All Curves


7.3. Execution Tools

Under the tools menu, we can view the execution time statistics and download the report.

Figure 6: Execution Tools


Execution Time Stats gives us a summary of time allotted to each work during the execution.

Figure 7: Execution Time Stats


Play Controls

Also under the Tools menu, we can hide/show the floating play controls (1). These floating controls also have an Info button (2) where we can review the worker execution as a bar graph.

Figure 8: Play Controls


7.4. Curve Viewer

Visualize your workflow through our curve viewer located in the Data Viewer section of the navigation menu. The following image maps out the curve viewer features listed below.

Figure 9: Curve Viewer

  1. Overlay Responses: Overlay all the curve inputs and outputs available in the workflow to compare and study
  2. List of all the workers with input and output
  3. Input and output: Inputs and outputs of every worker available for comparison and debugging

Add Curves to Basket

Click on the 3 dots next to an input or output curve in the viewer to collect them to be viewed separately. Switch on the “Show Curve Basket” button to view that curves added.

Figure 10: Add Curves to Basket


Saved States

New as of September, 2022, once we open the curve viewer, curve states will be saved, so we don’t have to wait for the curves to load. States are saved even after we overlay or change options as shown in the following video:



7.5. View Generated Report

Once our workflow has been executed, we can view our report we configured via the Report Generator Worker by clicking on this worker.

Figure 11: Click on Report Generator Worker


Click on “View Report” (1) to see an overview of the report via the PowerPoint Builder that can be downloaded as a PPT or PDF. Or, click on “View Simlytiks” (2) to study and interact with the report via the Simlytiks Application.

Figure 12: View Report and View Simlytiks


As of September, 2022, the PowerPoint Builder, now called the Reporter App, has a new look and feel. Here is how it now presents the report:

Figure 13: View Report - Report App


Here is how Simlytiks presents the report.

Figure 14: View Simlytiks


Reporter template input has a new option called Create LS-DYNA template (which is a collection of curves as 1x2 layouts).

‘Configure with options’ button is now available in Report Generator worker which includes Color By and Legend By features and can be configured using specified options.


Reporter dataset is now repeatable,and all repeated datasets are carried over to Simlytiks as separate sheets.

These datasets can be used in any visualization separately by 1. Creating a new chart and 2. Choose Data to Use option 3. choose viz options to render


Reporter now has a new input called ‘Simlytiks Config Mapper’ where you can map datasets from workflow to configs within Simlytiks like Inputs, Targets, Objectives.


If a dataset viewed in either Data table (or Overview table in Simlytiks) has a column called fparent_type, then the fparent_id will be a link opening up the corresponding type (simulation or physical test or workflow etc.)


Reporter worker has a new input called ‘Use Separate Sheets’ which when set to NO uses the new feature in Simlytiks where multiple datasets are shown as a dropdown in the header.



7.6. Workflow Collection

View workflow collection is now shifted to Files/library from tools.

Figure 14: View Workflows collection


Added new LS-DYNA Material validator to the workflow library.

Figure 15: Workflows collection


Feature importance learning is added to the library of workflows

Figure 16: Workflows collections


Generic Optimizer worker is added to the Library of the workflows.

Generic Optimizer


All library workflows are updated to ensure the files needed by the workflows are packaged. All workflows now should execute without an error about missing input files.


7.7. Workers UI for inputs

The worker inputs new UI view is simple and user friendly

Workers UI for inputs


Inputs for workers

Text inputs in start worker can have depends on dataset option available. We can add a dataset input in the start worker and allow the text input in the start worker to depend on dataset

Text input options in workers


Edit workflows

Edit option available for Workflows and workflows meta data can be edited

Edit workflows


Start workers merging

Now we have an option to merge two Start worker when we merge the workflows. Users have choice to select which two Start workers from the merging workflow needs to be merged


Editor

The file inputs in start worker have a new button EDITOR to edit text or image files


START worker File input can now allow multiple files. This setting can be changed in the 3 dots -> Validations Modal -> Max Files of the input.

Max Files


view RAW output and JSON button for failed workers

Now we are able to view the RAW output of the worker when the worker execution fails, we also have View JSON button in the worker logs where we the view the output


Workflows now has table view as another applications with bulk selections, filters etc.

Table View for Workflows

Re-arrange Header in workflow

Rearranged workflow header toolbar with a new dropdown for Export options, also moved a couple of view options to the View dropdown.

Header

Watch the following video to see viewing the report in action:

Workflows application is moved higher than Simlytiks

Workflows application is moved higher than Simlytiks.

workflows


Comments can be added to the saved Workflows

Comments can be added to the saved Workflows and we can see the user ID for the comment added.

Comments in Workflows

Validate workers

New option Validate is available under Tools option in Workflows to validate all the workers

We see paused message and dashed border for the worker when execution is paused in workflow.

Paused message and dashed border

Curve overlay for datasets

Now we have support for curve overlay of dataset curves along with other worker curves

Curve overlay for datasets

Simple input view

For input workers, Simple view type is made default view in Workflows.

Simple input view

All worker inputs have a new menu EDIT , VALIDATIONS , OPTIONS in Workflows.

EDIT , VALIDATIONS and OPTIONS

New input type called Worker input is added to Start worker, where we can add input to the selected worker and the input is assigned to the worker while execution of the workflow.

Worker inputs can be cloned now in Workflows.

Cloned Inputs

In Workflows, execution of any worker within the modal will show messages in the footer.

Execution Message

In Workflow, File inputs now have support to choose from sample files.


Sample Datasets are available for the Dataset inputs in Workers

Sample Datasets


In Workflow, when Default input fields are manually removed then these inputs will no longer be present.


Worker input has Default value, change this value to execute and reset to see the Default value again.


In Workflow, dataset input now has upload, download and reset features present below the table.

Dataset Input features


Worker input descriptions in list view are now colored in black

Input Descriptions


Repeated Input

Repeat plus icon is now available only on the last repeated input. If there are no repeated inputs, it shows up at the original input.

Repeated Input


Worker output view

Worker outputs now show inline data that can be enlarged on clicking for Dataset and Curve outputs.

Worker output view


Curve outputs show a preview of the larger curve in the outputs container when we open a Worker in Workflows.

Preview of the larger curve


In workflows, we now have preview available for Text outputs and Key value outputs in worker same as Curve and Dataset outputs.

Text output view

Keyvalue output view


In workflow, datasets with physical test, simulations or responses output can be viewed in ‘ID or Name’.

Output view


Output created using previous worker now has an option to ignore the worker names (along with their IDs) in the column names.


Outputs of workers having a download attribute for a file path can now be viewed & downloaded.


Input output view

In Workflows - IO View is now stepwise, groups autoplay once all inputs are filled in Start worker.

Physical tests created using CSV and EXCEL file

Physical tests can be generated from both EXCEL and CSV files using Workflow.


List input

Start worker has new option for the list input which allows to select the dataset and the columns from the same worker to the input.


7.8. Single selector Input

In a Single Selector Input, when multiple inputs are selected an alert message is shown as ‘SINGLE SELECTION ENABLED: Selecting the last term’.


7.9. Roles and Permissions

In Workflows, now we provide Roles and Permissions for Author and Viewer under settings option. We have options such as Manage Workers , Manage Views , Manage Commenting etc under settings.

Roles and Permissions


7.10. Download Multiple Workers

New context menu option added to Download Selected workers as Workflow (ZIP) when multiple workers are selected.

7.11. Copy and Paste Curves

Now we have support to copy any curve across the d3VIEW platform and paste curves in workflow worker inputs.

7.12. Remote Lookup

START worker remote lookup when chosen as workflows has a new option to fetch all remote workflow inputs and add them to current worker inputs.


Remote lookup inputs having particular dataType can now be coming from a previous worker dataset output with the same dataType


A remote lookup input will now show a button called View Simulation or View Physical Test right below the select input which should take you to the respective simulation/test in Workflows.


All remote lookup inputs will have an option to show the list as a carousel. This can be switched within Options dropdown under the input container. This is just another view type for the remote lookup list in Workflows ​


Remote lookup input in Start worker now has list of Master Templates that can be selected.

Remote lookup Template


7.13. Lucy Tab

Workers list has a new tab called Lucy and also Export options has a new option called Lucy JSON in Workflows.


7.14. Import File Option in Start worker

START worker has a new Import File option in the header which saves files to the START worker globally and any input can access this file using Data Source -> Existing files and the rules are saved
i.e. if the file is changed in Import File button, the input refreshes with the new value from the new file.

7.15. Edit Multiple workers

We can now edit multiple workers in Workflows even if the inputs in the workers are dependent inputs. We can edit text, curve and Dataset inputs in workers and save them to the Workflow.


7.16. Filters for Dataset Output

We now have filters which will pass on the filtered dataset during the assignment when Dataset outputs are used for Assignment to previous worker’s inputs


7.17. Workflow Provider

We can execute the entire Workflow by clicking on ‘View workflow’ in Workflow Provider and the worker also alerts if the current execution is running


In Workflow, while executing Workflow Provider worker, if it is interrupted by selecting stop then state of execution is saved and can be viewed in ‘view workflow’.


7.18. Edit Worker Inputs

We can now edit the name of the ‘Worker input’ in start worker.


In a Workflow, a worker’s input value can also be modified with the ‘worker input’ option that is available in the Start worker. If the input value is changed in either of the workers then other worker will also be updated with the corresponding input changes.


Replaced worker inherits the file from previous worker when worker is edited.


7.19. Grouping in Start worker

Added support for subgrouping in START worker when we use a ‘Remote Lookup’ to fetch workflow inputs and append them.


The modal title now changes to the corresponding input name when text area or text input is viewed by clicking on eye button.


7.20. GUI Selection

GUI Selection is now enabled for Decision workers if the validation is for a list input coming from Start workers.


7.21. Flow Modal

New option added to Workflows to enable Execution Flow Modal. User inspection inputs/outputs are getting initialized when we enable Execution Flow Modal.


After Enabling the Execution Flow Modal, We can execute the worker by right click execute options and by Run Workflow button available below the Start worker.


Flow Modal Execution also works if GUI and User inspection is enabled in Text Parameterize worker.


Workflow execution can now be done in a Flow Modal with at least one worker having either User Inspection enabled or an input with GUI selection then Execution in flow modal should be enabled in tools to view this flow modal.


Autoplay option is available in Workflows to execute Workflow Modal.


Flow modal in Workflows now supports ‘Worker input’ in Start worker.

Worker Input


We can now click on labels of the steps in Flow Modal to jump to a desired step while executing Autoplay in Workflows.

Flow Modal labels


7.22. Collected Outputs

Every worker output can now be added to Collected outputs, which is then shown in the Flow Modal outputs container after Auto Playing the workflow.

Collected Output


7.23. Export options

New export type option ‘Worker Names (xls)’is available in workflows page.

Worker Names (xls)


New option Download Error screenshot is included when a worker execution fails in a Workflow, This image will contain the worker config inputs on the left and the error message on the right

Download Error screenshot


For Workflow error alert now we do not show the worker description in the top and make the window look like error modal.

Error update


7.24. Use Previous Worker Outputs

Create Using Previous Worker Outputs for workers has new option choose Dynamic selection at the bottom of the modal If a worker is selected in the list (START worker for example) and dynamic is ON, next time if you add/remove any inputs within that START worker, this dataset input will update with all the latest updated inputs


7.25. Save as New Version

Save as New Version modal also has Switch to the new version option to change current workflow to the new version in workflows.

Save as New Version


Save As New Version modal now has the’Switch to the new version’ enabled by default. The current workflow working on will switch to the new version and all updates to it will reflect in the new version


7.26. Validations

Validations in decision worker or iteration END terminal can have operator value coming from any previous worker output.


7.27. OnePager

One Pager worker output has a blob output which is basically a FILE version of the one pager data. This will help d3VIEW execute Add One Pager to Physical test without the need to send all one pager data as simple string.

Blob Output


7.28. Sync Worker

Old workflows which have workers which are not Synced with Template will now have an orange border when opened and a clear message in the footer indicating the user to Sync with template to have the latest worker configs.

Sync Worker


7.29. I/O Mapper button

A new button is added in the header of a Worker Edit view called I/O Mapper which allows the mapping of any previous worker O/P to any input in the current worker based on the type of input.


7.30. Edges between workers

Edges between the workers have new option to ‘Map attributes between workers’ where we can map the inputs of the source worker to destination worker


7.31. Updated UI for Workers

UI update


7.32. Execution Stats

Execution stats in Top header or Flow modal header now includes a new option to change the time format for the ticks to minutes, seconds or milliseconds.

Execution Stats



7.33. Visualization charts outputs

We can view the Visualization charts in single page for multiple workers with visualization outputs in workflow. Click on Allow multiple charts option to view multiple chart outputs in a single page.

Visualization Charts Output



7.34. Cache worker

New option available to cache worker execution that will significantly improve workflow execution time. If the inputs have not changed, there will be no need to execute since the outputs will be same.



7.35. Multiple Edges

When a Worker is placed onto multiple edges, the edges incoming to this new worker are multiple.


7.36. Curve dependent on previous worker data

For a curve dependent on previous worker data, change Type of selection to Choose Curve From Dataset and auto select Row & Column which triggers the Data table curve selection, also better messages if dependent dataset does not have a value.